What You Should Know: Prerequisites

Transcript

In order to get the most out of this course you should be packing some prerequisites.

First, a familiarity with the Ruby programming language will be helpful, though not 100% required. Ruby is pretty easy to read and follow along with, though you will get the most out of the course if you know Ruby fairly well.

You’ll need a system set up to run Ruby. I’m using Ruby 2.6.2 for this course, but any version reasonably close to that will be good enough.

If you need help getting your system set up with Ruby, see the links posted in the next lesson.

You’ll need git in order to pull down the repo and follow along.

You’ll also need to be able to execute tests at the command-line.

The code editor of your choice. I’ll be using Vim with TMUX, but use whatever is most comfortable for you.

If you don't have an editor that you love or are simply looking for a change, I recommend you try the atom editor from GitHub.

Finally, you’ll need to know how to program. If you are an absolute beginner, this is not the course for you. Ideally, you have been programming professionally for at least a few months and have begun to experience the pain that this course addresses.

Discussion

0 comments